Need help with DRAM_LED issue


Limp Gawd
Dec 19, 2006
I'll make this succinct:

  • Have a Asus z77-M Pro mATX mobo + i5-3570k, working just fine
  • Decided to buy a new videocard, swapped it out
  • After swap, refuses to post, DRAM_LED either shows solid red for a seconds and then shuts back down or flashes and shuts down immediately
  • Removed motherboard from case, disconnected ALL (including video card as well as all HDDs etc.) peripherals and ALL RAM sticks, tried each stick individually in all 4 slots, still no dice - issue persists
  • Reset CMOS - success! Posts but tells me to go into BIOS first
  • After going into BIOS, behavior above persists until I reset CMOS again - but again can't get past BIOS
I'm ordering a new stick of RAM on the off chance that I managed to fry all 3 of my existing sticks, but I'm also worried that that this might be a motherboard issue. The DRAM_LED seems to suggest that it's a memory issue, but I'm also unable to get this motherboard's MemoryOK self-diagnostic to run properly (unless I'm doing it incorrectly?). I also don't understand why it posts right after I clear the CMOS, but then stays stuck after.

Any thoughts or perspective on how to solve this would be helpful. Thanks!
Sounds like your problem didn't arise until you stuck in new video card. Remove video card and return it. Unless you fried something installing it. System works ok with old card??
As I mentioned, the problem now exists even on a minimum setup - no HDDs or expansion cards, and running off integrated graphics.
Maybe some kind of ESD damage to motherboard. Sounds strange. Maybe something got damaged when you were putting the card in. Maybe knocked off a surface mounted resistor or something.

Fire up the Hirens and PC-Check and start testing stuff.
...which I would if I could get it to get past POST and boot. Right now, I'm only able to get it to POST when I reset CMOS, but then it forces me to go into BIOS and after that, the problem recurs.
Well, only idea I have left is pull the CMOS battery and let it sit for a while then put battery back in and reset it with the jumpers and give it 1 more go. If that doesn't work it is time for a new motherboard unless it is the PSU. Sounds like MB tho.
I have done that and the board consistently posts past a CMOS reset, but then goes back into the loop issue.
So the issues seems to have fixed itself, and I'm not sure how or why. I got a new stick of RAM and changed the CMOS battery after leaving the mobo untouched for 2 days, and it boots up fine. All previous RAM sticks also work and memtest86 reports no errors after 4 passes. I think changing the CMOS battery likely had the impact, or just letting the motherboard fully discharge.

Sharing for anyone else who stumbles upon this thread in the future.