Limp Gawd
Jan 3, 2014
Gigabyte GA-Z97MX-Gaming 5 / i5-4590 / 8GB G.Skill DDR3 Ripjaws X / GTX 970 / Corsair CX550M / Windows 8.1 64 bit / 1TB Toshiba HDD / 1TB WD Blue HDD / 2TB Seagate Firecuda HDD / 500GB Adata SSD as my boot drive. The Toshiba and WD drives still have windows installed on them, I use the ssd as my boot drive and have for about a year without issues.

The issue I've had since a couple of days ago is that the boot order changes itself in the UEFI/BIOS overnight and randomly while I have steam downloading several games. What i did a couple of days ago when I started downloading was change the power settings to never sleep, and left it overnight with my account locked. In the morning the monitor was on standby, the computer was still on, but with no hdd activity according to the HDD case light, the keyboard led back light was still on so the peripherals were functional, but the computer wouldn't wake from keyboard or mouse input. So I turned off the pc and turned it on, it booted slowly, but after a lot if confusion and panic I realized it booted from my WD drive. I knew something was wrong because the desktop was different, the system reserve partitions were showing in My Computer and the drive letters were different. So I got into the UEFI and saw the boot order was different, I fixed it to have the ssd boot first again and restated. It booted fine this time, but apparently it had finish a windows update first, once that finished it restarted. This time the screen was extremely pixelated, but the screen resolution was correctly at 1080x1920 and DPI was correct. So I restated and all was good again.

Fast forward to the next morning again letting it download overnight. I wake up today to find the monitor black, but I could tell the back light was on and it wasn't in standby mode. The computer again was on with no hdd activity light, keyboard and mouse lighting up, but the computer wouldn't show anything or wake. I turned it off and on, it didn't boot, so I turned it off and went into the UEFI, to find that the Seagate drive (which does not have an OS on it) was now the first boot priority. I changed it back to the Adata SSD as the first boot priority, and it booted fine this time. This was about 6 hours ago and so far it was fine.

Now, another 4 hours later I check up on the computer again, and the same thing happened. Both my connected monitors have the backlight on with no image, are not in standby, the keyboard LED backlight is on, the computer is on and unresponsive. I turn it off, go into the BIOS and see that the DVD/CD Drive is first in the boot order. Fix it, and it boots fine. Except I find that my F: drive which is the WD Drive is not accessible and it gives me an error about a corrupted recycle bin. After some research, I ran chkdsk in the command prompt and have it in stage 4 looking for bad clusters with about an hour to go. Hoping my motherboard isn't dying or worse, my data being lost.

I'm not sure what could possibly be causing this to happen. Is it a failing drive or is my ssd dying? Could it be the motherboard? Could it be that the computer is getting a windows update and then automatically restarts in the middle of steam downloading, causing some kind of conflict or glitch that is causing my problem? These are just guesses, I'm unsure about why this is happening.
Any help or insight into this is greatly appreciated. Thanks!

TL;DR: Downloading steam games during the day and left overnight to continue downloading. Sleep setting set to never sleep to allow downloading to continue overnight. Find computer on in the morning, but not waking and unresponsive. Find boot order in UEFI is different, fix it to correct boot order and boots fine. Unresponsive again, boot order different again, fixed and boots fine again, but one drive now inaccessible. Happened twice now.
I can say that windows updates have messed with my drives b4 but that was with raids having drives missing.

You problem could be any number of things, a dying SSD or HDD, defective Sata port on the mobo, a messed up bootmanager, defective power supply (corsair CX ones are know to have issues).
Standard advice for bios problem--try replacing the battery. Standard advice for downloading problem--go through device manager and make sure power management is disabled for all network ports and devices so that they are not accidentally powered down. Also check control panel power management to make sure all disabled.
Since posting, the new main issue that has arised is my F drive, a WDD 1tb, has become in accessible. What I've done since posting is run chkdsk for the drive in question, with no issues from it. Also System File Checker said there were some corrupted files, but it couldn't fix some of them. I looked into the log file it created, but I couldn't find what drive the files that weren't fixed were in, they have no typical file path name, like they're registry keys I think.

I also tried changing the permissions to F drive full control for administrative accounts, which mine is, but it gave me an error saying one xml file couldn't have the permissions updated because access was denied. After it finished that, still didn't work.

So then I ran Hard Disk Sentinel to see if it was a dead disk, but it said it was perfectly healthy.

The last things I can think to do are change the sata cables and cable order, unplug all drives but the ssd boot drive and the F drive. I believe the drive is still functional and has the data on it, but something happened to make it un accessible. All from some boot glitches while downloading games?
Assuming the OS isnt screwing you over, it could be that a drive is disconnecting and reconnecting at times.
Possibly due to a fault, dodgy bios or bad connection.

The corrupted files problem seems to point to this as well.
Assuming the OS isnt screwing you over, it could be that a drive is disconnecting and reconnecting at times.
Possibly due to a fault, dodgy bios or bad connection.

The corrupted files problem seems to point to this as well.

What would be the course of action to fix this if the BIOS is the culprit or for the other possible reasons you stated?
How old is this 1TB WD, you might want to start backing up what you can from it?
Boot order shouldn't be a issue unless the pc is restarting or shutting down? what gives? I think you need a good look at the event log!
What would be the course of action to fix this if the BIOS is the culprit or for the other possible reasons you stated?
Reset the CMOS and set it up how you like again. See if the problems stops.
Look to see if there have been firmware updates beyond the version you are using that address hard drive issues.
Unplug everything and reconnect in case a bad connection anywhere is causing electrical issues.

If a drive is faulty it should be removed.
Try disconnecting the drives one at a time to see if anything changes.
Change your bios battery just in case. Weird crap can happen when it's failing. Check your sata and power cables. Test the WD drive in another computer or an usb enclosure if you can. And check your event log for clues!
I disabled other boot options other than my ssd boot drive, so hopefully that works, but I'm going to try recreating the problem by leaving the computer downloading games like before.

I'll go through the event logs. I'm going to recover the data from the F drive because one way or another I can't access it still in Windows, I'm not sure if it's a hardware or software issues. I'll also change the sata cables with a couple new ones and if the problem persists I'll replace the cmos battery.