Xpenology ESXi OVA template?


Oct 25, 2011
Hi guys, does anyone knows where one can get an OVA template of Xpenology? I am trygin to find that but with no success.
I don't know of any. I would deploy one with base config, then create one for future use.

If you are trying to deploy it. I think I used this guide- https://ithinkvirtual.com/2016/04/30/create-a-synology-vm-with-xpenology/

It's actually not nearly as bad as the instructions make it out to be. There is a pic for nearly every step and it turned out to be a lot easier than I thought. Just make sure to use the proper xpenology versions.
yeah... xpenology.me/downloads links are not working :/ any alternative source?
I have the original 5.2-5644.5 and 5.2-5644.7 .img files, and ISO's saved
You can get the .pat's directly from Synology

Seems like the project has died off and isn't as popular as it was a few years ago..
Found this tutorial for upgrade/install of 6.0.x- https://xpenology.com/forum/topic/7507-tutorial-installmigrate-dsm-52-to-602-juns-loader/

The DL links appear to work but I've personally not used it. I'm still on 5.2-5967 and surprisingly still have the files as well. I'm not sure if jlbenedict shared the files but if you need, let me know. I put them up on google and can send you the link.

Also going through installer now with the files I have to see if I can create an OVA.

And FYI... if you are watching console to boot and only seeing 169.254.. address, check your DHCP for the MAC assigned to the VM to get the real IP.
Last edited:
  • Like
Reactions: qhash
like this
Thank you guys. HF is the best forum ever :).
DSM 6.x version is said to have no support for virtual environment, at least thats what I have read.
Outlaw85, if you can assembly OVA template, that would be perfect. Do you use 5.2-5967 as a VM in ESXi ?
@jibenedict if above is not possible ato achieve, I will ask fot the files you have.
Last edited:
Just replied to your message.

It should have everything you need to deploy (all necessary files and/or OVA). NOTE- OVA is untested but the VM was functional before converting. That is good to know about 6.0. Last I read about it was several months back when they got it working. I didn't see on what platform.

Yes. I run 5.2-5967 as a VM in ESXi. It's been really stable since I started it several months back. I only have it running plex though so not much load from it. There does appear to be a lot of functionality in the package manager I just haven't had the time to play around with yet.

Any questions, don't hesitate to ask. I'll be happy to answer anything I can.
Ok.. so much work, thought its gonna be easy friday. I will check this out after the weekend and I will let you know wheter OVA you have prepared works or not. thanks again.
lol. c'mon! I have faith in you!. If the OVA doesn't work, it really isn't bad to configure from scratch. If first time running through VMs, sure, I'll give you that. It does seem overwhelming. Once you get through the end of the doc though... you'll be "oh, that was it?" :D

Let me know if I can help. I won't be able to jump into esxi or anything but should be able to try answering questions if needed.
I'll try to upload the files I have to gdrive sometime late tonight (can't do it during the day.. uploading kills my DSL connection) :D
hey, cant load the OVA file. Seems its either incompatible with my EXSi 6.0u2 or both my browers hung up during file decompression. I will proceed with standard install. Thanks for trying
That sucks. Just curious, did you tried the thick client? We've had to do that at work. Sometimes it's easier or it just plain works better with the thick client.
Sorry it took so long. I was finally able to test the OVA and it does in fact fail but was successful from the template. I'll see if i can recreate and test one for you.
I have tried vSphere client today. I totally forgot its still available for 6.0.
I receive an error stating: "unexpected end of OVA file while looking... [] "
Outlaw85 I have did a clean install from the scratch, so do not waste your time creating an OVA template. Thanks a lot for your help.
Last edited:
Glad to hear you got it figured out though. Everything working so far with a clean install?