Win 10 USB Mass storage device no longer working


Dec 5, 2007
Ok I am stumped here I have been using this same USB3 HDD SATA docking station for years and now Win 10 suddenly won't show any HD that I attach with it. Win 10 only sees the thing as a USB Mass Storage Device, but not the actual attached HDD. And I can't seem to fix it.

When plugged in Device manager has the warning icon and it's status is:
This device cannot start. (code 10)
A device which does not exist was specified.

I have tried "updating" the driver and there is none and it was working less than 2 months ago when I used this same device to prepare several 8TB HDD I am now using in on this machine. The device and drive attached to it is working fine and so are the USB ports on the PC since I rebooted to linux and the drive works fine there. So it is most definitely an issue with Win 10.

I tried sfc along with DISM to check for system file problems and there were no problems.

After googling there is only one thing I saw that I could try but I am not sure how to actually do it as it requires you to uninstall all the USB controllers in device manger and reboot, but how do you do that when you are using a USB kb and mouse which will stop working sometime as you uninstall the USB devices?

It only seems to be affecting this one device. As the mass storage drivers seem to work fine for flash disks and even another old generic USB 2.0 HDD to SATA adapter.

So any suggestions would be welcome.
Reinstall your motherboard drivers. Windows 10 probably replaced them automatically because it found a "better" one.
Could this be the age old Windows stupidity with drive letters? Windows tries to mount the drive to a reserved drive letter and it fails. If that's the case you have to manually change the mount letter in the storage settings.
Have you tried the dock on another system to rule out the possibility of a faulty dock?
Yeah it works fine on my old i7-3770k, and like I said, it works fine on this PC when I booted into linux earlier. It was working fine less than 2 months ago on this PC with this windows 10 install with no issues when I put in several 8TB drives. But yesterday nothing, and today still nothing works. It just shows a USB Mass Storage device but not the HDD in the dock. I'll retry the motherboard drivers but IIRC I did look at those already and there weren't any changes, but it can't hurt to uninstall them and reinstall it again just to be sure.

It shoudn't be the drive letters as windows doesn't see the attached HD at all (ie it doesn't show up in disk management).
Have you fully powered off the computer, unplugged it from the power and waited a couple of minutes? Could be that after booting into Linux, something is going on with the hardware and a power down and disconnect might help.
Yeah I fully powered down, not for a couple of minutes, but for a good hour and it didn't do anything. I ended up installing the HDD during that time to the internal SATA ports to get it up and running and doing the testing and disk copying that way. BTW that was before I even ran it in linux. I have tried several HDD, all of which work and can be seen on the i7-3770k w/ Win 7 but not in Win 10 on the AMD TR rig in my sig. It really feels like a driver issue, but there just isn't any driver for this as it never hand one in the first place as it is built into windows. The Win 10 troubleshooter didn't do anything either.
Just to update, it seems it is a problem with the device. I think I might have been mistaken when I thought I setup the 8TB drives on my Win 10 AMD rig but thinking back I probably did it a few days before I built my AMD rig and I last used it extensively on my Win 7 rig. After some digging I found the HDD Dock I use has a firmware update that fixes HDD recognition issues under Win 8.1. So I am guessing the same applies to Win 10.

After trying to upgrade the firmware it still won't work so I am thinking I will just buy a new HDD to USB3 docking station. I tried one firmware upgrade that said it went through but is still not recognizing the HDD in win 10, and the other firmware update seems to not work at all on the docking station, so it looks like the simplest solution is to just spend a bit of money for a new one. Though I have to say it's still doesn't sit well with me, not because it's an expensive piece but it shouldn't have to be replaced at all given it is working fine in other OSes with no issues.