Weird Ethernet Issues Post Power Outage - HELP


Nov 4, 2011
To start out, there was a power outage this last week when a transformer blew, and after it came back on this is when everything started. Mind you, everything worked flawlessly before this happened.

The relevant hardware: I have an old media server with an EVGA 780i FTW, and a Q9550. The system works okay still other than being outdated as a big plex/Kodi library. I HAD a motorola surfboard Sb6121 hooked up to a Netgear R7000 nighthawk running DD-WRT. These were not on a good surge protector. I have windows 7 on my media server, and it had a decent surge protector. I had every intention of upgrading to windows 10 but the deadline is now 2 days away and I can't get internet on it to do so. When the power outage hit, the desktop was off, but the modem and router were not because who ever turns those off?

So first, I called comcast after the power came back on because the internet was out. They told me my modem was defective after I could not get it to connect to the ethernet port on my desktop. I was skeptical because they had told me this before when they were having issues and let's be honest they're pretty deceitful and unhelpful, but I digress. I immediately went out and bought a new SB6183 Modem because I realized either way it's an outdated modem I've had like 4 or 5 years.

So I get the new modem, and after spending many hours talking to different trained monkeys at comcast to try and get it to connect, it finally works.

HOWEVER - for whatever reason, connecting the modem directly to my desktop's ethernet port, or connecting the R7000 router to it, it'd just show the red x and doesn't even recognize a cord was plugged in. (on a side note, just idling now, the R7000 I have is constantly above 80C and often above 90C)

After tinkering with the router, I suspected it too might be bad, so I tried my old Linksys WRT610N router with DD-WRT and hooked it up to the modem, hooked it up to the same desktop, and then it worked as flawless as it could being on such an outdated router. I was able to get internet, wifi, and I was able to connect it to my desktop ethernet port and it worked. Good speeds too for an old router but subpar for streaming 1080p and 4k content on our local network.

Naturally thinking that this was of course then a router problem I went out and bought a Linksys WRT1900ACS router (stock firmware), and a nice cyberpower 650va surge protector since I suspected that was a big cause of the problems. Basically I blew $400 on equipment after this outage so I could have the internet again and stream my media to my TV, which I really don't have any business spending.

So I get the nice new WRT1900ACS setup, it works with the wifi, all my other devices in the home connect fine via wifi, However, it won't connect to the ethernet port on my media server desktop which is probably the #1 use I get from a router on a daily basis. I uninstalled and reinstalled the Nforce network drivers, reset TCP/IP, I've tried numerous things. Nothing I do on that desktop allows for it to connect via ethernet to the new linksys WRT1900ACS or the Netgear R7000. Doesn't show a light on the router either.

This is where it is so odd though. I'm not even sure what caused me to do this, but I had the WRT1900ACS hooked up to the modem and that to the coax. When restarting the computer, it doesn't connect, it gets the red X and no lights on the router. The router and modem both will connect to other computers without any issues.

However, I still had the old WRT610N hooked up to the power only, so what I did was I took the cable out of the new WRT1900ACS router, plugged it in briefly to the WRT610N, and of course as before the desktop recognizes the connection. Then, if I take it straight from the WRT610N and plug it back into EITHER the R7000 or the WRT1900ACS, all the sudden it recognizes the connection on my desktop and it gets the internet, and both routers light up.

So basically as is, I just spent $400+ for a new modem and router, but they only work if I plug my old WRT610N into my desktop ethernet port first, then remove it and plug it back into my new router. If the desktop is restarted it's back to square one.

That's obviously not a long term solution. My guess is the ethernet ports were damaged, however before I go buy more hardware such as a new NIC, I wanted to ask if anyone had any similar issues they've experienced, and if so how they solved them. I have a couple days left where I can return the new router which I will do if possible since it's sounding more to me like that wasn't my issue, but then again the temperatures on the R7000 are high. As of now, I have a brand new modem and router, but the only way to get them to work as normal is plug them in after I use my old one.

Please help...