Very slow login to XFininity; email issue

philb2

Gawd
Joined
May 26, 2021
Messages
1,002
Just wondering if anyone else has these problems with Xfinity.

Starting last month, sometimes it takes several minutes to log into Xfinity.com and seems stuck in some kind of endless loop. Is this an issue with my Firefox browser or the web site.

My email issue that I use Outlook on my Windows 10 Pro 64 system as my email/calendar/to do/contacts application. Again, in the last month, the Outlook mail folder counts don't update when messages are moved or deleted. This morning I had 73 downloads in my inbox, so the Inbox folder showed a message count of 73. But, about half the messages were automatically filtered into the spam folder. For the rest, I sorted them into High, Medium, and Low priority folders, so that the inbox itself was empty. Yet the Inbox mail count did not change from 73.

The only workaround is to log into Xfinity webmail. When I did that this morning, at first the webmail inbox count also showed 73. Then a few seconds later, the count reset to 0. I selected some other folders like Sent, and then also reset. So what is going on here? Is this some weird Outlook problem, or a problem with Xfinity?
 

philb2

Gawd
Joined
May 26, 2021
Messages
1,002
Last edited:

philb2

Gawd
Joined
May 26, 2021
Messages
1,002
time to talk to xfinity(on the phone). hitting 0 a bunch will usually get an agent.
And there is yet another issue. All my new emails are going to the TRASH folder, instead of the INBOX. W-T-F is the matter with Xfinity?
 

AgrFan

[H]ard DCOTM x2
Joined
Sep 29, 2007
Messages
625
I have no problems with my Xfinity email using Thunderbird. I highly doubt Xfinity is the cause of your issue. It's possible though.

You may get better help in the Xfinity Community Forum.
https://forums.xfinity.com/topics/email-and-web-browsing/602d56f9e6b3965d18e3a597

Do you have any filter rules setup on the Xfinity side?
https://forums.xfinity.com/conversations/email-and-web-browsing/new-email-goes-to-trash-folder/602db124c5375f08cd46ac7d#

Have you verified your Outlook settings?
https://www.xfinity.com/support/articles/email-client-programs-with-xfinity-email
 
Last edited:

philb2

Gawd
Joined
May 26, 2021
Messages
1,002
I have no problems with my Xfinity email using Thunderbird. I highly doubt Xfinity is the cause of your issue. It's possible though.

You may get better help in the Xfinity Community Forum.
https://forums.xfinity.com/topics/email-and-web-browsing/602d56f9e6b3965d18e3a597

Do you have any filter rules setup on the Xfinity side?
https://forums.xfinity.com/conversations/email-and-web-browsing/new-email-goes-to-trash-folder/602db124c5375f08cd46ac7d#

Have you verified your Outlook settings?
https://www.xfinity.com/support/articles/email-client-programs-with-xfinity-email
Ive done nothig to change my outlook config, but the problems have mostly cleared up. mostly. i'm still going to call xfinity per message #4.
 
Top