used internal SSD not opening on a different device


Nov 3, 2021

I had two mac computers ; one macbook pro 17'' and one mac mini 4,1.
I decided to remove the ssd from my macbook (which was bearly running anymore) to my mac mini in order to impove my mac mini's perfomances.

I followed instructions to do so through a tutorial, and successfully installed the ssd.
But then when trying to turn on and use my mac mini, the session could open (it was stuck on the log in screen).
So I tried to install mac os on it again, as I had read that i could solve the problem ; it was unsuccessfull.

Now, I successfully installed mac os on an external hard drive in order to be able to use my compter.
But still, I can't figure out a way to use the internal ssd to run my system from.

I tried checking the health of the ssd, with DriveDX and it seem to be in good condition. I also tried to repare the ssd through disk utilitary but it didn't work. I even tried to erase the ssd but it also didn't work.
So I can't figure out where the problem is, and how I can solve it.
I don't beleive the ssd is incompatible but the ssd is a KINGSTON SUV300S37A480G
I would also like to mention that the ssd wasn't the reason why my macbook pro wasn't usable anymore.

If anyone has an idea or had similar problems, I'm desperate for help.

Thank you


*English isn't my first language so if anything that I said is unclear, please forgive me