Upgraded from RX 480 to Vega 56, no signal problem


Dec 5, 2018
I used to play on an RX 480 (as per title) and got a Vega 56 during Black Friday ( https://www.asus.com/us/Graphics-Cards/ROG-STRIX-RXVEGA56-O8G-GAMING/ ).
Only got around to plugging it in yesterday, expecting it to not be too difficult to get running. No such luck. I have no signal whatsoever from it. No POST. No BIOS. No nothing.
The red LEDs on it go slowly on and off when computer is on. No idea if it's meant to do that. It has a small light to indicate it gets power from the two 6+2 pins required and both are on. The fans spin for a few seconds when powering on the computer, then stop.
If I plug in HDMI (not tried DVI for this but I assume that works too) into the integrated motherboard HDMI port and unplug power to the Vega card I get signal and can boot to Windows just fine.
Upgraded BIOS that way just now, nothing's changed.
I've no idea how to fix this or even what's wrong. Help please.

Motherboard: MSI Z170A Gaming M5
CPU: Intel 6700K I think..? Should have checked when I got into Windows I guess.
RAM: 16 GB, unsure of brand and model but obviously DDR4.
PSU: Corsair something something modular 750W. Connected to GPU via two cables and not just one shared 6+2.

Going to boot into Windows, uninstall all Radeon stuff, restart and reinstall, but other than that I've just no idea what to do. And considering I don't even get a signal to get into BIOS I'm not sure that will solve anything.
Sounds like a dead card to me. You could try reseating the card, or putting into a different slot I guess, double check the power cables are correct then RMA it.
Dead card. Are you still within the window of time to swap it out at the store you bought it from? Much faster to do that than to send it in for an RMA with the mfg as you will end up just getting either e refurb or somebody else's faulty card.
Ordered it from an online store. Talked to them now and will just send it back to them and they'll take a look at it.
But bummer, was pretty excited about it. And now that particular card isn't in the store anymore, so not sure what they'll do if they have to send a replacement.
Send it back. This is why I buy pre-tested cards if used or getting sent from overseas.
had a similar issue on a recent repair i was doing... similar card, and chipset... i spent a lot of time trying to isolate the culprit and after playing the ram game, pulling all unnecessary cables/cards out of pc... i just reinstalled the original card so i can boot again, and flashed the motherboard with the latest bios, and bam! re-inserted the upgraded clients GPU of choice, and all was perfect. Called Gigabyte to ask why such issue was fixxed with a simple bios update, and it was explained that between something with the gpu bios needing or NOT needed secure boot device ID's, etc, etc..... latest bios eliminates that need and actually that bug was fixed many bios revisions ago, but this board had a 2 year old bios on it. YOu have nothing to loose OP, try flashing board with latest bios and see if your issue is the same as what i encountered! good luck
Flashing the BIOS was one of the first things I managed to do. :) Still the same issue. So looking like a dead card.
Flashing the BIOS was one of the first things I managed to do. :) Still the same issue. So looking like a dead card.
oh, i guess reading failed me yet again, i do see now in your post you did say you did that, im sorry!