Unable to access BIOS thanks to HDD password and when HDD is out, there is no option to disable HDD password - unable to boot

postcd

Weaksauce
Joined
Nov 24, 2016
Messages
92
Hello,

there was Windows 10 on a HDD and in BIOS (Lenovo Flex 2) i have set HDD password which was asked before boot. Now after i have used dd command to restore different operating system to drive, and reboot to check if it worked (it did), i have found that there is HDD password prompt and providing password fails to unlock the drive.

I have tried various keys like F2, F12, F8, Fn+F2,12,8, Del, dot before during and after this password prompt and it not allowed to get into BIOS. After removing the drive and getting to BIOS (Fn+F2), the option to change HDD password is inactive.

"Hard disk passwords are stored in the firmware of the drive." - https://web.archive.org/web/2021122...com/how-to-reset-hdd-password-on-dell-laptop/

Someone mentions "there is a HDD password defined as part of the ATA specifications" (means it is not set on the disk but in its firmware)
And indeed, i have used wrong password.

By the way here is possibly how to reset/disable HDD password:
A) Windows software claimed to reset HDD password: https://web.archive.org/web/20210503080203/https://techviral.net/crack-hard-disk-password/
B) How to unlock an ATA password-locked HDD with an upper-case password if the BIOS accepts only lower-case?
He says: "I succeeded by plugging the drive in an old PC and issuing hdparm --security-disable PWD /dev/sdb. The drive is now reusable."
I guess he is talking about some Linux system/or Linux USB installation disk with live/preview mode. Myself i am using https://gparted.org/liveusb.php which has dd, ddrescue, gparted, and hdparm too built in.
Yet for me that hdparm command returned:
hdparm-hdd-password-reset.jpg

+ on reboot, password prompt remained. If anyone have idea what could be wrong or how to enter BIOS, please comment.
 

Azrak

[H]ard|Gawd
Joined
Oct 4, 2015
Messages
1,072
PWD means the actual password. Unless your password was "PWD", you need to try running the hdparm program again:
sudo hdparm --security-disable <password> /dev/sdb
where <password> is your password, like "sudo hdparm --security-disable mysecretpassword /dev/sdb"
 
Top