Strange powersupply problems have me baffled.


Limp Gawd
Jan 17, 2005
Hey All,

I'm at my wits end with this one and need some advice. I have a Lenovo Y720 Cube w/ i5-7400, 16gb GSKIL, and XFX RX480 8g running at 2560x1440. The original issue was that the computer shuts off randomly when playing WoW. It is very random in game, but I'm able to reproduce the problem by running Furmark at 2560x1440 resolution. Furmark runs fine at lower resolution, but as soon as I start the stress test at 1440p - shutdown!. I've tried an identical XFX GPU and the original reference RX 480 that came with the cube as well. I've tried several driver versions as well.

I read about other people complaining about the factory AcBel PC7033 450w PSU, so I swapped the original for a brand new EVGS 450w PSU. Bingo, no crashes. Everything that caused crashes before is resolved. But... there is a new problem. When the cube falls asleep, all fans off, power button blinking, it won't wake up with mouse or keyboard actions. The mouse or keyboard causes a brief flash of the case lights and fans, than it shuts off completely. I have to use the power button to wake it, and it is more like a reboot, than a wake from sleep. It takes longer, and it registers with Windows Reliability Monitor as an unexpected shutdown. Waking with the power button instead of the mouse or keyboard wakes it correctly. It is like the mouse or keyboard cause it to fail to wake, and then I have to revive it with the power button. I've tried other keyboards and mice, and different USB ports to no effect.

I assumed something was wrong with the PSU install, so I pulled and reinstalled it, no help. I removed the PSU and installed a larger Corsair TX650w to see if maybe there was something wrong with the EVGA, but the Corsair has the exact same problem. I thought maybe it was a setting in Windows, and since I was going to give the PC to my daughter, I went ahead and formatted and reinstalled windows. The problem persisted. I really feels like a hardware problem.

Last weekend, I reinstalled the factory AcBel 450w PSU and used the pc for a week - NO SLEEP / WAKE PROBLEM - but the crash when certain games or stress test are performed came back. After a week of good sleep/wake behavior, I reinstalled the EVGA 450w and now it works for all stress test, but the Sleep/wake problem came back.

I don't understand how the cheap factory AcBel PSU is the only one compatible with this hardware platform, and a good brand like EVGA and Corsair wont work.

Any thoughts from the forum???