RAM Issues on X58 Boards


Just Plain Mean
Staff member
May 18, 1997
Please post in this thread ONLY if you have had troubles with X58 motherboards "dropping" memory channels. Say if you install 6GB and it tells you have have 4GB installed or install 12 and tells you 10 or 8 is installed. Please tell model and revision of mobo as well as a quick write up as to what the issue is EXACTLY.

This issue does not seem to be one of any specific brands as I have seen it on ASUS, GBT, MSI and many reports of EVGA boards. My theory is that we have some "bad" DIMM slots being installed on motherboards. I would love to hear what you have to say as well if you have experienced this problem first hand.

Anyway, we need to get the issue out in the open and get it solved as it has proven to me over the last month to be a issue that needs to be specifically addressed.
Last edited:
I thought this was an EVGA only issue, but I guess it's not. Sometimes for a few it has been as simple as re-seating the CPU, RAM or changing some BIOS settings that's as far as I know concerning the EVGA boards. Had no idea it was a widespread problem.
i was having very finicky issues w/ the IMCs on core i5s too, happened on an MSI board (MS-7588) and an ASUS (P7P55DLE)
i was having very finicky issues w/ the IMCs on core i5s too, happened on an MSI board (MS-7588) and an ASUS (P7P55DLE)

I saw something similar on LGA 1156 boards a few months ago. It all came down to putting too much pressure on the CPU in the socket. This is not the issue with 1366 as I have spent a lot of time proving that to myself.
Happened to me when I was installing my XMS3 ram in my Foxconn mobo, I had to go in and manually set timings and voltages, otherwise it would be 6GB( 0.99 usable)
EVGA X58 SLI, 6gb installed 4 gig detected = RMA replacement was fine.
SuperMicro MBD-X8DAH+-O, 12gb installed, 6gb detected and at times 8gb or 10gb, quick rma to newegg and all was fine after that.

Gigabyte GA-EX58-UD4P: no issues to report.
I've had all kinds of issues on my EVGA x58 SLI LE and my 6 gigs of G.Skill. First board was rmaed with a dead ram slot. Its replacement currently sees all 6gb, but the memory settings in the BIOS have to be set a certain way, or I only get 2 or 4gb of usable memory in windows. I haven't had a chance to push my overclock very high, cause once I start messing with stuff I lose 2 or 4gb of ram. Glancing over the EVGA boards, this seems pretty common, as there are usually a few threads a day on it.
EVGA X58 Tri-SLI, 24GB installed, Usually 16GB detected but sometimes even 8GB or 22.5GB. Some software would say I was only running dual channel. This happened on two different sets of memory (G.Skill and a generic brand. Have two threads here and here detailing the problems).

Dicked around with my BIOS/reseating everything for a month to no avail, was finally fixed by randomizing the order of my DIMMs for a while. I couldn't find any clue to help me along the way (i.e. no signs of certain sticks preferring certain slots or anything)

Edit: It might be worth nothing that this problem only occurred on my i7 980x. When I dropped my old i7 920 back in, it seemed fine.
Last edited:
Five weeks ago I build an i7-920 system with an EVGA 132-BL-E758-A1 X58 mobo and 3 x 2GB Mushkin RAM and dual GTX 480s.

Upon first boot, apparently I had this occur and didn't notice it at POST, as Windows 7 was reporting 4GB of RAM once it was installed. My first thought was wrong version of Windows, but no. I went ahead and installed updates and rebooted.

I think the BIOS was also reporting 4GB, so I looked in the BIOS for any possible settings causing this. (First i7 build, was not familiar with this BIOS.) Seeing nothing, and not willing to first think of Mushkin RAM as bad, I did a CMOS reset.

I have not seen the problem since. And I did not physically do anything inside the system to the CPU HSF or RAM at all. No physical adjustments.

I have experienced one hard lock with the system. And the computer was doing absolutely nothing at the time. Go figure.

The system is semi-OCed. (I haven't attempted to find its limit...)

But I mentioned all of this as although I've only seen it happen once on its first time of being turned on, and although I run it 24/7 and rarely even reboot (right now it's been up 12 days, last reboot before that was nine days previous as well), I still remember to watch for it on every reboot...

(I also learned the hard way that a CMOS reset turns off the RAID function of the Matrix controller in the BIOS and breaks your array if you forget to change it back... This is why I stopped my OC attempt halfway... So, I watch for two things on every reboot...)
I went through 3 RMA's on the EVGA X58 SLI LE for a build (don't recall the specific revision, it was a few months post release at that time). It either wouldn't post with dimm #1 populated (retail board), or would report really weird totals like 4.5 (RMA #1), or 3.99 (RMA #2). I finally got a board that worked right (RMA #3), but it was a huge hassle that spanned over about a month.

6 gigs stopped working, only 4 reporting in. Granted this was AFTER I had a water cpoling leak and lost 4 gig of ram. 6 was originally working. Strangest thing too because its the very last slot that you use for triple channel. It was the slot/RAM that DID NOT get wet or have an opportunity to get wet. It was the only RAM stick left working.

Haven't messed with it much. I remember reading something about loosening up the CPU cooler will make the RAM start registering. I did have to tighten mine down A LOT.
On my Asus P6T Deluxe v1 I had no problems, it recognized all 6 sticks of my ram. But on my Gigabyte x58-EX-UD5, it would only recognize 10GBs out of 12GBs. Looked in the bios and saw it was running my 1.5v RAM at 1.65v, so I turned it down to 1.5v. The mobo saw all the ram but would lock up, I bumped the memory voltage up several times by .02 increments and it kept crashing in Windows, until I set it to 1.6v, then it saw all memory and did not crash.

So running at the wrong voltage could be causing at least some of these issues people are seeing with not all their ram being recognized, in addition to whatever else causes this.
My brother's Asus P6X58D Premium has had memory issues (showing only 4gb of 6) even after an RMA. He did some research and found that it may be due to a short caused by an incompatibility with the mounting system of the TRUE Spirit heatsink and his mobo. Last I heard he was going to pick up some nylon washers and remount to see if that fixed things.

My EVGA x58 SLI has had minor RAM issues as well. I have 6gb installed and from cold boot it frequently takes a ridiculously long time to post. From what I can tell it retries POSTing a few times until everything checks out, sometimes it goes on the first try sometimes it takes a full minute, but it's always from cold boot. The error code readout displays F3 F6 and F8 during each 'cycle' of the boot attempts. Last time I looked it up I believe I was told these were RAM related despite having the problem persist with 2 sets of ram and being completely stable in windows 7, prime95, and memtest.
So running at the wrong voltage could be causing at least some of these issues people are seeing with not all their ram being recognized, in addition to whatever else causes this.

Voltage played a role in my instance as well. I've only had my i7 system for a week or so, but have seen it report 4G instead of 6G once. I was dicking around with the QPI voltage at the time and had it set around 1.35v or maybe a little higher. A restart and backing off on the voltage caused the issue to disappear. One of my sticks of memory has tested out as bad, so that clouds the picture a bit.

I'm using an i7-930 in an ASUS P6X58D-E with OCZ 1600C8 1.65v memory.

If I see the issue again I'll take better notes :)
I have only had this happen once in the whole time I have had this system since the day the board was released. From day one I never had a problem at all using the same memory through all bioses until F13i or F13j bios thats when my problem started. I am now on f13k and I can actually make it do it and replicate it by setting timings to tight and actually running the mem overly aggresive easily with varying degrees of voltage it will drop 4 gigs in the bios. And in the bios it will have horizontal lines where the timings should be but what is funny cpuz and windows 7 still shows 6 gig but only 2 being able to be used.
I'm not so convinced that it is faulty RAM slots. I would think it is more of faulty traces or connections on the motherboard itself.

I worked at a plant that did R&D and built automobile electronics and other automobile systems.

There were certain circuit board manufacturers that we were always having issues with... NANYA being the worst one. Sometimes the solder wouldn't flow properly on the faulty boards and would end up ruining thousands of dollars of product.

Other times it was the solder masks or the reflow ovens having issues with not working properly.

I would look into who is providing them with the boards and/or putting the boards together. My guess is that there is a common link somewhere.
I have a set of 3x2gb sticks and it's been doing it on the two boards I have tried it on msi x58 platinum sli as well as a evga x58 sli le. I was going to try it on my zotac x58 and asus p6t ws. I tried this with different cpu's and it did not seem to make a difference. Also memtest sees the 3 sticks but only addresses 2 of the sticks.
Would it not also be relevant to ask exactly what slots are dropping out also kyle. to possibly see if that was a certain pattern also. mine that drop out are slots 3@5 which in turn im thinking might lead to the first slot getting enough voltage where the next 2 dont possibly just a thought at least.

6 gigs stopped working, only 4 reporting in. Granted this was AFTER I had a water cpoling leak and lost 4 gig of ram. 6 was originally working. Strangest thing too because its the very last slot that you use for triple channel. It was the slot/RAM that DID NOT get wet or have an opportunity to get wet. It was the only RAM stick left working.

Haven't messed with it much. I remember reading something about loosening up the CPU cooler will make the RAM start registering. I did have to tighten mine down A LOT.

Exact same situation with with my Asus Rampage II GENE. Slots never got wet but now only seeing 4gigs. Change voltages and bought new ram. Still the same.
I hate to see this thread now that I just shipped off my cousins I7-930 with 3 * 2GB.....She's 12 hours away driving so I hope it posts correctly.
I have the EVGA X58 SLI LE(BIOS ver. 74) with the I7 930 and 6GB(3x2GB) of GEIL 1600 8-8-8-28. I have Windows 7 64 bit installed it shows 6 GB with 3.99 GB useable.

And if I had not seen this thread I would not have checked mine.
Last edited:
I had major issues with this: http://hardforum.com/showthread.php?t=1543591
copy/pasted my solution from that thread:

Well this thread gave me some ideas.

RMA board arrived today, threw all 6 slots in it, booted. 16GB... no worries, didn't do anything in the BIOS so there was some hope left: upped QPI, enabled the weird asus bios option "lock memory settings" or something like that, etc. Reboot. No dice.


Decided to be systematic about it, so tested each stick in each slot, or was planning to. I already knew the black slots don't work if there's nothing in the red, so I started with the red. The serials on each stick end in 80, 81, 82, 83, 84 and 85. So I used those as my labels. Right off the bat I found 80 and 81 didn't work in the slot farthest from the socket, what I'll call "C." was pretty frustrated thinking this board had another set of bad slots. Got to 82 though and it booted! 83 was good to, 84 no, 85 good.

so 80, 81, 84 didn't work in the farthest slot, and 82, 83 and 85 did.

I threw 82 83 and 85 in the red slots, thinking those were my best sticks that worked in all slots, trying to get the board to recognize 12GB with 3 sticks, think it worked, but it may not have, can't remember at this point, but it may have cause I moved on to testing all 6 sticks/24GB. 16GB again. Dicked around in the BIOS for about an hour, upping/lowering QPI and IOH trying to find some ratio that would work... nothing.

Then it struck me that the black socket furthest from the socket may be 'weaker' than the other 2 like the red ones... took one of the good sticks that was in the red slot closer to the socket, plopped that in the furthest one, rebooted...

sad to say that now that everything is under water and rigged up (although still in a test bench and not the case) the POST screen is again showing 16GB instead of 24.
Gigabyte GA-X58A-UD5 (rev. 1.0)
G.Skill 6GB F3-12800CL7T-6GBPI
i7 975 EE and now an i7 950.

6gb of memory, would mostly detect 4gb but occasionally detect 2gb or very occasionally the full 6gb.

Swapping memory around just confused me, I would think I tracked it down to one module or slot but that was just proven wrong on the next boot. BIOS F5 on that board would just POST with whatever it found, BIOS F6j (beta) would detect the problem and do a continuous restart loop with message "recovering lost memory" sometimes it would take five tries or so but it eventually completed POST with the correct 6gb of memory. With all 6gb detected it would pass memtest86 and act completely stable under IntelBurnTestV2 or anything else I threw at it. The challenge was merely getting all the memory detected on POST.

Under the advice of G.skill support via their forum I replaced the memory and I was fixed, it always detects correctly now.

I tend to think that it isn't RAM, RAM slots, BIOS or any of the mainboards. The memory controllers in the CPU are sensitive to current spikes & increasing voltages beyond 1.65v would slowly cook them as some OC'ers found out....It's got to be the CPU not responding well to the voltages or clocks being applied...
ExcePt that most of the time it happens right after new parts arrive.
Posted via [H] Mobile Device
I have a ASUS P6X58D-E with 6gigs of Corsair Dominators. Bios and Windows can only see 4, yet CPU-Z will show I have 6. I haven't done very much to see if I can fix it (I need to do a ramtest overnight) and yes I am OCing an i720.
i7-920, Asus P6T Deluxe V2 with G.Skill 6gb DDR3-2000 (9-9-9-24). Having some issues but I'm not done with it yet.

I have it OC'd of course.

Multiplier 21 x 190 (3.990ghz), 1.35 CPU Voltage - Only way I can achieve 4.0 with this board/processor. Have tried manually putting in the timings 9-9-9-24 with 1.6-1.65 dram voltage and tried using 1.45 QPI voltage. I have some more things to try and I may have to lower my O'C which I don't want to do. The guy I got them from had an EVGA board and he nearly had a 1:1 ratio with DDR3-2006.

Everything I tried last night would only see 4gb installed in BIOS. Setting everything to AUTO resulted in seeing all 6gb but the ram running at DDR3-1200 speeds using CPU-Z to verify.

If anyone has some good pointers, I'll gladly try them.

G.Skill F3-16000 9-9-9-24
I finally gave up after trying to get it to run any faster than 1600 with my 3.990 OC. Even with a lesser OC it would have taken entirely too long to figure out the settings. I literally tried every QPI voltage and it would never stablize under Intel BurnTest. After going up to 1.5v QPI and it not being stable, I gave up.

There might be some good I guess, It is stable @ 1595mhz with 7-7-7-20 timings, 1.32 QPI. Also, when I get a differen't motherboard & processor this ram should finally see its glory.
I don't think the purpose of this thread is to discuss overclocking problems. Many simply have a problem getting memory to show up at stock/default rated speeds.
Well, I don't believe it, but I'm running into the same problem on my brand new gigabyte X58A-UD3R. First time it booted with 6GB (3x2) showing up in windows and bios, but one or two restarts later and its only showing 4. CPU-Z's memory tab shows all 3 slots populated with the correct information. Windows 7 64bit shows 6GB installed but only 4.00 "useable" I haven't had time to fully explore the situation, but initially it sounds exactly like the problems being reported

Everything totally stock, UD3R with i7-950 and OCZ gold DDR3 1600
I am like everyone else here; MeM problems during POST not calculating correctly, sometimes it will be 10GB, then other 8GB and once in awhile 6GB. I run with a i7 920 on a GA-X58A-UD5 with 12GB GEIL Black Dragon PC3 10660 1333MHz CL 7-7-7-24, yes I overclock; depending upon what I am doing at the time (rendering or word processing) I run 2.8GHz @ 1333MHz C6 to 4.01GHz @ 1504MHz C7. I just came off an P6T utilizing the same CPU & RAM and on both boards I had the same problem. While on the P6T I RMA'D the CPU at ASUS'S request, the TECH told me (after trouble shooting via phone Virginia Beach, VA to someplace in CA) that his test prove its the MeM Controller onboard the CPU. After CPU replacement problem persisted so I had the board RMA'D; not once but 3 times! The problem remained. I can say this about the GIGABYTE board: during POST if the MeM count is bad I can turn off the power, wait a few seconds till everything settles down and then turn on the power again and usually during this 2nd Cold Boot the RAM is counted correctly. After that I can Restart the computer a thousand times and the RAM will always count correctly. But allow the machine to be turned off and become cold, turning on the computer will invariably give a incorrect MeM count during POST.
I have tried various adjustments in the BIOS from voltage to MeM timings, flashed the BIOS to the latest and greatest (FB) all to no avail.
I was just about to order some different RAM when I checked this forum and found all you people having the exact same problem I have, so I shall save myself some cash and keep plugging along here with what I have. My problem is not quite as bad as some of you for I can live with mine. -end-
irvinj in Virginia Beach, VA w.GA-X58A-UD5 LGA1366, i7 920 @ 4.01GHz, 12GB DDR3 C7 @ 1504MHz
irvinj: you sound exactly like what I was having, seems that they inserted that reset loop into newer BIOS revisions to address the problem. My problem was solved by replacing the memory.

It's strange but it seems like there is something weak in the way the memory is detected, maybe something borderline or special in the way the bloomfields process SPD info?
Asus P6TD in December. Installed 6GB detected 2GB. Did an RMA. RMA board saw all 6GB. I think pressure may be an issue. If I clamp down full force with the Venomous X on that board it sees 4GB. Backing off the pressure seems to work as it sees 6GB with less force. Asus PT6 V2. Saw all memory, full force, no issues. Intel taking the pins off their chips -- dicks.
i have following

1x Evga X58 SLI (the first version)
1x Evga X58 Classified with NF200
2x W3520
1x i7 980x
1x i7 920 C0
1x mushkin 6-7-6-18 12GB 1600mhz
1x mushkin 7-8-7-18 12GB 1600mhz
1x G.Skill 7-10-10-28 12GB 2200mhz

i will have randomly unusable RAM but after spend few hours randomly reseated, oc, overvolted, underclock until bios see all my ram then if it is untouch it will be usable since then. after updated bios i have to go thru everything aging which is very frustrated.

but form what i know is this is bios level problem not OS problem for sure. and i already stop figuring about why for about 5 months now i think it is all about luck like going to vegas
Something is rotten in Denmark and I am not sure it is not the DIMM slots. I boot my system today, it shows 8GB of 12GB. Take the door off, move the DIIMs around, get 12GB on my second boot. I have a BRAND NEW Rampage III Formula showing me the same thing......I have seen this on MSI, GBT, and ASUS with X58 boards..
This happened on my EVGA X58 SLI when I was pushing the BLCK too high. I'd change the voltages around, lower the blck, eventually it would detect all 3 DIMMs again.
Looking forward to it. Right now my 3rd Asus Rampage Gene III is working with all 24GB but it's happened before and then stopped again.
SuperMicro X8DAi, Dual E5520 Xeons, 12GB, showed only 10GB a couple times after I first set it up, moved sticks around, and started working just fine, never had an issue with it afterwards. I marked which slots I put each ram into and did memtest on the ram, no issue ever again.
I just changed MoBo's on a i7 rig a few weeks back. Went from an ASRock x58 that died and went with an eVGA x58 SLI Mobo (132-BL-E758-A1). When I first booted it up, it registered 4GB of 6GB. I left the DIMMs alone and went about OC'ing it. It is a dedicated F@H box so wasn't worried about missing 2GB of RAM and at the time did not have time to mess with it (figured I'd deal with the issue later). After getting the OC's set, it started registering 6GB. That was again a few weeks ago and it hasn't changed. I just thought it was a fluke, but since it did "fix" itself, I didn't think anything of it.