R7 250x GPU Pass through ESXi 6.0


Limp Gawd
Feb 27, 2006
Been trying to Passthrough a R7 250x GPU in ESXi 6.0.

The drivers install with no issues, and no issues in device manager.

However, when going to Radeon Settings i get an error saying "Radeon settings are currently not available Please try again after connecting AMD graphics."

I get a similar error with or without the HDMI audio part of the card pass through.

I have an actual monitor hooked to the card as well.

This is what I get with GPUz
Having a new issue now, on 6.0 and 6.5 with when I goto install the amd drivers it detects the hardware, starts installing after selecting custom or express install...before it completes the VM shuts off. No error or anything...just off.

In windows 8.1 and 10 vm's.
Sorry I hadn't seen this earlier. FWIW, I have not tried passing through a Radeon of any stripe. I have been able to pass through a Quadro and Geforce 1050 Ti. The Quadro worked flawlessly with no special configuration. However, when trying to pass through the Geforce I got a code 43 error in device manager. I resolved that by altering the VMs config file (a.k.a. .vmx file) with:

hypervisor.cpuid.v0 = "FALSE"

This "tricked" the NVidia driver to load for a consumer card in a VM. Maybe it will help with your Radeon...