Multi-monitor getting jacked up in Hyper-V

fatryan

[H]ard|Gawd
Joined
Feb 19, 2004
Messages
1,390
I run a Win10 Pro VM in Win10 Pro on my home machine for working from home. I don't want my company accessing my files, so I connect to their VPN and RDC into my office machine within this VM.

I have a problem when I reduce the screen from full-screen enhanced mode. I can reduce or minimize it without issue, but when I go to maximize again into full-screen, everything gets all messed up. Sometimes the VM doesn't display across all my monitors, other times it does. But 100% of the time, the RDC connection within my VM screws up the windows pretty bad. Its hard to explain what it does exactly, but it screws up the splitting of screens such that I'll have a split in the middle of a monitor (see attached screenshot). Usually I can fix this my minimizing and maximizing 1 more time, but today...after installing new monitor mounts, I cannot get it to correct itself. It makes no sense how monitor mounts could affect this, but this is the first time Ive been unable to get it back to normal. The only workaround is shutting down my VM and restarting it.

multimonitor.png


My home machine uses an AOC U3277PWQU & Dell 1908FPt (old AF). I dont know the model Nos. of the monitors at work, but I have 2 similarly-sized (though not identical) Dells. I want to say they're about 20" and near standard aspect ratio for modern monitors. My office machine runs Windows 10 Enterprise. VPN is Palo Alto Networks Global Protect and we use RDC to connect. Don't know if any of this matters or not.

Any idea what's going on here? Suggestions on a fix?
 
Not sure if you're using Hyper-V. I can say using VMware workstation I regularly throw 6 monitors at it and haven't had any weird issues like this.
 
Not sure if you're using Hyper-V. I can say using VMware workstation I regularly throw 6 monitors at it and haven't had any weird issues like this.
I actually switched to vmware workstation a while back and I'm not looking back. It's so much better than Hyper-V.

Though I sort of still have this same window issue. It seems to be related to the nested remote desktops connections, but I discovered if I minimize the RDC to my work first then minimize my VMWare window, i do not have this issue. I recently picked up a samsung g7, so now at least in using two matching monitor sizes. But i still have the window issues if i don't minimize each separately.
 
Yea, in 3d settings if I recall correctly. Been a minute since I ran an nv card.
 
Yea, in 3d settings if I recall correctly. Been a minute since I ran an nv card.
I found the surround settings, but it will only let me do 1080p @ 60, which won't cut it for me. I guess my gpu is too low end for this feature to be particularly useful.
 
Back
Top