logitech scrollwheel & red hat 9


Limp Gawd
Jul 11, 2002
I'm a complete n00b in linux and have just installed redhat on my desktop for getting used to the environment (I use red hat at work). One thing that's just ticking me off is the fact that the scrolls wheel (buttons 3, 4, and 5) are not detected at all on my installation. I've tried looking online for any help but nothing seems to acknowledge mouse drivers. Anyone got any info? I have a slightly dated logitech cordless freedom (with the wireless mouseman)
You enable the scroll wheel in the X configuration (XF86Config).

The relevant stuff in my XF86Config.

# Identifier and driver

    Identifier  "Mouse1"
    Driver "mouse"
    Option "Device"     "/dev/input/mouse0"
    Option "Protocol"   "ExplorerPS/2"
    Option "Buttons" "7"
    [B]Option "ZAxisMapping"    "4 5"[/B]

The ZAxisMapping line tells it you have a scroll wheel and to assign the wheel to do up and down when you scroll it.

edit edit edit: by the way, your XF86Config is located in /etc/X11/
EDIT: I was too slow. Just read above. Was checking out another thread while I let this window behind.~

Well, I'm guessing this would work, but I'm not sure. Don't have that mouse, I just use an old intellimouse. Maybe you could post the mouse section of your XF86Config for more help.

Edit your XF86Config (/etc/X11/XF86Config) and scroll down to the mouse settings.
On the Protocol, use "IMPS/2".
Add an option called "Buttons" with the value "5"
And add another one called "ZAxisMapping" with the values "4 5"
I checked in my XF86config and found the section you were talking about...but the zaxismapping line is there.....it seems like it should work fine but for some reason it doesn't...is there anything that could be overriding the config file?

EDIT: I also found this line...

Option "Emulate3Buttons" "no"

in the config file. just wondering if that has any relevance since I didn't see any of you mention it
Here's the code out of my XF86...

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "PS/2"
	Option	    "Device" "/dev/psaux"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "no"

Section "InputDevice"
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
	Identifier  "DevInputMice"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "no"
well looks like I screwed something up good now. I found an option through KDE which let me choose my mouse. It was set to generic 3 button mouse so I tried a few logitech models. after none of those gave me results I tried "generic wheel mouse" and now my mouse has gone haywire. any movement causes it to blip across the screen like a turkey on acid (think mouse sensitivity = NULL) and it will randomly click whenever i just tyr moving the mouse. Is there any way I can rerun this mouse chooser from the command line?