Logitech K800 keyboard stopped working when I plugged in my new M510 mouse

Deadjasper

2[H]4U
Joined
Oct 28, 2001
Messages
2,311
I think it tried to pair with the unified transceiver and failed and now it doesn't work at all. Google is useless and down right stupid when trying to find any info on this problem.

I tried the K800 on another computer using the original transceiver and nothing. And of course I replaced the batteries. Resetting the K800 via holding down the escape key while powering on does nothing. Meanwhile the M510 is working just fine.

Anybody know how I might bring the K800 back to life?

PS - This is an illuminated keyboard and the lights work just fine.

TIA :)
 

Deadjasper

2[H]4U
Joined
Oct 28, 2001
Messages
2,311
Update for those who may run into this issue.

Part of the problem was I use Linux. If I were using Windows I would have installed the Logitech Pairing utility and that would have fixed it. Once I realized this I was going to plug the keyboard and mouse into a Windows PC and pair them there but decided to see if there was a comparable utility available for Linux and there was. It's called Solaar and it works perfectly. I'm typing this on my formerly dead K800. Happy Happy Joy Joy.
 
Top