Help diagnosing laptop problem

nomar

[H]ard|Gawd
Joined
Jan 30, 2002
Messages
1,404
I have an old HP DV4000 that I'd like to use as a server. (vortexbox.org).
It was running fine with XP a few months ago. I recently installed Puppy linux and it works fine but... now when I hit the power button, it is hit and miss if it boots.
Sometimes it will power on and do nothing.
Sometimes it will power up and start to boot but hang.
Sometimes it will start loading puppy and freeze on one of the steps.
Sometimes it will boot puppy and freeze intermittently.
I put the XP HDD back in and it does the same thing.

It *seems* like there is sometimes an effect when I tilt the screen up and down... like there is a loose wire. But it doesn't help all the time.

I removed and reseated the processor. I removed and tried different RAM. No help...

Any suggestions before I trash this thing?

Thanks!
 

nomar

[H]ard|Gawd
Joined
Jan 30, 2002
Messages
1,404
HP Specs

Integrated graphics.

I just took off the keyboard and power switch pad and everything is tight and properly seated. Also, it is not a charger/battery issue.
 

nomar

[H]ard|Gawd
Joined
Jan 30, 2002
Messages
1,404
Well... I've just discovered that I can make it boot EVERY time if I give the keyboard a good pound with my fist.
 

starhawk

[H]F Junkie
Joined
Oct 4, 2004
Messages
8,908
Rather than test the impact resistance of the keyboard, I'd look and see if you're not getting a short from a loose wire.

Could be a loose HDD connector, could also be a trace on the mobo that got loose if you were phenomenally clumsy. Could also be the wifi antennas... those things are a devil to get connected properly.

Or it could be a bad keyboard.
 

YeuEmMaiMai

Fully [H]
Joined
Jun 11, 2004
Messages
31,502
^ I like the pound the crap out of it option, that way he can replace it with another PC....
 

starhawk

[H]F Junkie
Joined
Oct 4, 2004
Messages
8,908
Hey, Pentium M stuff is still viable. Most of the stuff in my house runs Pentium M. It's cool.
 

nomar

[H]ard|Gawd
Joined
Jan 30, 2002
Messages
1,404
It isn't a wire to the HD, I booted a live CD with no HD present and it did the same thing.

I also removed the internal wifi card and taped off the antenna wires.

This wasn't my laptop... it was given to me so I don't know the history of it being dropped or anything like that.

Oh well, it's not worth screwing around with. The LCD is in great shape so I'm just going to part it out and sell it.
 

starhawk

[H]F Junkie
Joined
Oct 4, 2004
Messages
8,908
I might be interested in this depending on price and whether or not you like trades.

Shoot me a PM if you'll consider sending all of the laptop to one destination. Er, I'm kinda poor so you might get hit with what most people call a "lowball". I call it "this is what's in my wallet" ;)
 
Top