Creative Labs Refurbs. G5, G6, X3, AE-5. $69.99-$99.99

maro

Gawd
Joined
Aug 27, 2006
Messages
733
https://us.creative.com/p/refurbished

Discussion in this thread lead to led to mention of Creative's refurb deals. I decided to post them here because they seemed like decent prices if you don't mind refurb'd. Thx to DooLocsta for the link.

G5 = $69.99
G6 (previously out of stock) = $99.99
X3 = $79.99
SBX AE-5 = $79.99

Looks like a 90 day warranty on these. I have a X3 on the way.
 

MavericK

Zero Cool
Joined
Sep 2, 2004
Messages
31,344
I have the X3, it's a nice unit. Hard to find DACs that also support analog speakers and have hardware controls.
 

LurkerLito

2[H]4U
Joined
Dec 5, 2007
Messages
2,462
Not impressed with my MB audio out, it's functional but it's not nearly as good as the one on my old ASRock Fatality board that had a Soundblaster built in. I have been on the fence about getting an X3 or the new X4 but for $80 I figured why not give it a try. Thanks op.
 

Centauri

2[H]4U
Joined
Mar 1, 2003
Messages
2,181
I grabbed the G6 (refurb) last year. Love it. I actually wound up ditching the EVGA NuAudio that I was running.

Great software, and having a sound card isolated from the rest of the system makes so much more sense.
 
Last edited:

pandora's box

Supreme [H]ardness
Joined
Sep 7, 2004
Messages
4,771
I grabbed the G6 (refurb) last year. Love it. I actually wound up ditching the EVGA NuAudio that I was running.

Great software, and having a sound card isolated from the rest of the system makes so much more sense.

Nice! I ordered a refurb last week, should be here Wednesday.
 
  • Like
Reactions: maro
like this

LOCO LAPTOP

[H]F Junkie
Joined
May 4, 2006
Messages
11,797
In for a SBX AE-5. Thanks OP.

Should be a solid upgrade over my SB-X that just started to give issues. Was thinking about the G6 but ill grab one later for my laptop.
 
  • Like
Reactions: maro
like this

maro

Gawd
Joined
Aug 27, 2006
Messages
733
I'm still waiting on my X3. Ordered the 7th, Creative shipped it that day, then sat 7 days at DHL for some reason. I finally got an update the 14th. It might show up this week. This appears to be DHL delay not Creative and the order did say 12th-19th for delivery.
 

tantalus

Limp Gawd
Joined
Apr 25, 2006
Messages
248
Noob question, but are these worth getting for listening to Spotify? I have a decent pair of cans (Sennheiser 580s) but am not sure whether streamed music would benefit from a dedicated sound card or not. I also play games like BFV, but don't need a soundcard for that. Mobo is in sig.
 

TheToE!

[H] Brewmaster
Joined
May 17, 2005
Messages
8,390
Noob question, but are these worth getting for listening to Spotify? I have a decent pair of cans (Sennheiser 580s) but am not sure whether streamed music would benefit from a dedicated sound card or not. I also play games like BFV, but don't need a soundcard for that. Mobo is in sig.
Absolutely.
 

Ikasu

[H]ard|Gawd
Joined
Jul 24, 2007
Messages
1,204
Man...On the fence. I've already been burned MANY times by creative. With their own products, onto the X-FI Prelude made by auzentech, to the Asus Xonar series. The drivers and software support from creative has always been hot garbage. I moved onto a Schiit Stack of a Magni 3+ and a Modi 3+. It's alright, I have to run Equalizer APO with Peace add on to get the sound profile to something I enjoy. I do miss some of the sound processing features my xonar and previous X-FI cards had. Checking online, people having issues with even the external dacs as well from Creative...but at that price, it's tempting to try. Bah...this is hard. I would completely skip it if I didn't have a need for sidetone. On top of the fact that my Schiit gives me this weird audio screeches/pops/desync in premiere/after effects, but works fine everywhere else, leaves me wanting a bit more.

Yea, want sidetone though, I may bite, but man...tired of getting burned by creative, saying never again, only to fall for their shit again -_-.
 

DooLocsta

[H]ard|Gawd
Joined
Jan 26, 2005
Messages
1,713
I received the X-3 and when it works it is great but I am pretty sure this one skipped QC. It is still broken, light do not work correctly and the outputs are very messed up. Hopefully the replacement will be better.
 

Solhokuten

[H]ard|Gawd
Joined
Dec 9, 2009
Messages
1,416
Been rocking the G6 for a couple years now. Its a fine device for gaming and music with a nice pair of headphones. The high gain switch can feed my headphones that require a bit more juice to get the most out of them.
 

LurkerLito

2[H]4U
Joined
Dec 5, 2007
Messages
2,462
Just got mine and installed it. It seems to be working well so far. Sound quality is definitely better than the onboard audio of my motherboard. But there does seem to be a minor issue with the software. It didn't seem to remember my settings on reboot. I have my speaker setup as 5.1 but when I rebooted it was reset to 2.1 and instead of it being on EQ mode Movies where I left it, it was back to direct. Does this happen normally to any long time owners? I didn't notice any save settings button in the SB Command tray icon.

Overall I am really liking the audio quality. It's like a muddiness has disappeared in the music and movies I tested. Vocals are especially improved just from a couple of quick tests I have done. I have should have done this sooner. :)
 

OFaceSIG

2[H]4U
Joined
Aug 31, 2009
Messages
3,251
Just got mine and installed it. It seems to be working well so far. Sound quality is definitely better than the onboard audio of my motherboard. But there does seem to be a minor issue with the software. It didn't seem to remember my settings on reboot. I have my speaker setup as 5.1 but when I rebooted it was reset to 2.1 and instead of it being on EQ mode Movies where I left it, it was back to direct. Does this happen normally to any long time owners? I didn't notice any save settings button in the SB Command tray icon.

Overall I am really liking the audio quality. It's like a muddiness has disappeared in the music and movies I tested. Vocals are especially improved just from a couple of quick tests I have done. I have should have done this sooner. :)
If you're talking about an x3 I had the same issue. You have to go into the settings and tell it "only PC mode" or something like that. By default it's set to be console compatible and it forgets the PC settings with every reboot.
 

LurkerLito

2[H]4U
Joined
Dec 5, 2007
Messages
2,462
If you're talking about an x3 I had the same issue. You have to go into the settings and tell it "only PC mode" or something like that. By default it's set to be console compatible and it forgets the PC settings with every reboot.
Thanks. Yeah it's the X3. I changed the setting, so next time I reboot I will find out if it stuck.
 

mvmiller12

[H]ard|Gawd
Joined
Aug 7, 2011
Messages
1,233
Thanks. Yeah it's the X3. I changed the setting, so next time I reboot I will find out if it stuck.

If it doesn't, get your settings back where you want them and try putting the computer to sleep, waiting a minute or two and then waking it back up.

Srsly...

I have an X-Fi card, and I have to put the computer to sleep to get it to remember settings changes between reboots.

Edit: Figured I'd add that the only thing I don't link about my X-Fi card is the fact the the master volume control doesn't work when using Optical Output with Dolby Digital 5.1 encoding. Individual volume controls for programs in the mixer work just fine, but master volume is always maxed out. On the Creative Reddit I asked about this once and they said it wwas working as intended, and that they can't "change" the DDL output signal... and yet my Auzentech X-Meridian 7.1 managed to do it just fine.
 

Porter_

[H]F Junkie
Joined
Sep 10, 2007
Messages
8,428
I’ve been using an X3 since it launched (purchased the day of release) and I’ve been very happy with it. I use it exclusively in Direct Mode with no software intervention. Coming from an X-Fi Titanium HD and JDS labs O2, I can say there is no noticeable difference in sound quality using my HD650 headphones. That’s high praise as far as I’m concerned.
 

maro

Gawd
Joined
Aug 27, 2006
Messages
733
G6 better for headphones
X3 is good with headphones but also has discreet speaker out

I do not have a G6 to confirm this and am not a frequent user of headphones but this was the impression I got while debating between the two. I went with the X3.
 

Ikasu

[H]ard|Gawd
Joined
Jul 24, 2007
Messages
1,204
Tad bit more than that for a difference, the G6 isn't an SXFI solution. So if you were looking for SXFI, not a feature of the G6.
 
  • Like
Reactions: maro
like this

tantalus

Limp Gawd
Joined
Apr 25, 2006
Messages
248
https://us.creative.com/p/refurbished

Discussion in this thread lead to led to mention of Creative's refurb deals. I decided to post them here because they seemed like decent prices if you don't mind refurb'd. Thx to DooLocsta for the link.

G5 = $69.99
G6 (previously out of stock) = $99.99
X3 = $79.99
SBX AE-5 = $79.99

Looks like a 90 day warranty on these. I have a X3 on the way.
Thanks OP, purchased an X3.
 

SixFootDuo

Supreme [H]ardness
Joined
Oct 5, 2004
Messages
5,825
Man...On the fence. I've already been burned MANY times by creative. With their own products, onto the X-FI Prelude made by auzentech, to the Asus Xonar series. The drivers and software support from creative has always been hot garbage. I moved onto a Schiit Stack of a Magni 3+ and a Modi 3+. It's alright, I have to run Equalizer APO with Peace add on to get the sound profile to something I enjoy. I do miss some of the sound processing features my xonar and previous X-FI cards had. Checking online, people having issues with even the external dacs as well from Creative...but at that price, it's tempting to try. Bah...this is hard. I would completely skip it if I didn't have a need for sidetone. On top of the fact that my Schiit gives me this weird audio screeches/pops/desync in premiere/after effects, but works fine everywhere else, leaves me wanting a bit more.

Yea, want sidetone though, I may bite, but man...tired of getting burned by creative, saying never again, only to fall for their shit again -_-.
I've been a Creative guy since the early Sound Blaster days. Early on I do not really remember encountering a lot of bloatware or issues. However, over the last 10 years with Creative, I have experienced bloatware and slow updates in fixing the occasional annoying bug, not that I can remember what any of them were these days. Long story short, I think the new software for both the X3 and X4 are clean, better UI, efficient in quickly changing / adjusting settings. Also, Creative has been pushing a lot of updates, driver updates and new firmware updates to the point, I am shocked at the level of support. The new software even alerts you to new updates which I really like. I recently moved to the new X4 because of how much I loved the X3 and the new UI is even better. I am pretty sure you will not feel burned this time around. Lot of good vibes in here from all of the feedback on the X3 and I think trust does not come easy from the HardOCP community. Most of us have been here 15 - 20 years which dates many of us into the mid to late 30's to the 40's and even into early 50's +
 

Ikasu

[H]ard|Gawd
Joined
Jul 24, 2007
Messages
1,204
I've been a Creative guy since the early Sound Blaster days. Early on I do not really remember encountering a lot of bloatware or issues. However, over the last 10 years with Creative, I have experienced bloatware and slow updates in fixing the occasional annoying bug, not that I can remember what any of them were these days. Long story short, I think the new software for both the X3 and X4 are clean, better UI, efficient in quickly changing / adjusting settings. Also, Creative has been pushing a lot of updates, driver updates and new firmware updates to the point, I am shocked at the level of support. The new software even alerts you to new updates which I really like. I recently moved to the new X4 because of how much I loved the X3 and the new UI is even better. I am pretty sure you will not feel burned this time around. Lot of good vibes in here from all of the feedback on the X3 and I think trust does not come easy from the HardOCP community. Most of us have been here 15 - 20 years which dates many of us into the mid to late 30's to the 40's and even into early 50's +
I feel you. tipping into my 40's soon, have used Sound blaster products literally for the last 20+ years or so. Always have had a dedicated sound card, this is the first time around I went external with my Schiit stack. The problems I've had with creative products over the last 10-15 years specifically annoyed me to know end. Trying to get away from creative directly, to auzentech X-FI didn't help, and asus xonar as well. My biggest problems were during the X-FI Titanium time frame and onward, onto my X-Fi Prelude from auzentech, in an effort to get away from creative support, but the auzentech was still plagued with lack of driver support/updates from creative on the product collaboration. Switched over to a Asus xonar Essence STX II, which is literally just sitting in a box now. Over the last three cards mentioned, had blue screen issues, random ear piercing screeching issues out of nowhere, which would require me to restart my pc to get my audio back. Also BSOD's EVERYTIME I would format and try to resinstall the drivers, and when switching from speaker to headphone for the first time would BSOD. After that, it would work fine...

Literally being forced to go to 3rd party drivers to get the hardware I purchased to work somewhat is just not a good sign. Looking up the X3, G6, etc online via reddit and troubleshooting searches on google leads to a ton of posts of people with random quirks and software issues...Which has me thinking it'll just be the same shit...lol. Overall I've been decently happy with my Schiit stack, not as good as my essence STX II was in certain aspects, but after using Equalizer APO, I've got it to a state that is not bad...But do miss certain features from my last two sound cards. I remember watching the first of the Star Trek remake films on my old setup, the amount of detail and clarity I picked up on the opening sequence to the film was insane. Listening to it on my schiit, just doesn't do my memories justice. I know if I toss in my Xonar I would get that feeling, but not worth the driver issues/hassle.

I would be completely content with my schiit stack if it worked fine in premiere/after effects. I solved the side tone issue by using a rolls minimix II, and merging my Line 6 UX2 audio out into my schiit audio stream via the mini mix before it hits my headphone amp. This way I get the sidetone I need as I run my XLR mic via a line 6 interface, and use my schiit stack for my main audio source. Have individual volume control over each via the mixer....Ahhh, the lengths I go to for sidetone to enhance my DND DM capabilities =P. I see all these streamers picking up GO XLR's and what not, but my Line 6 UX2 offers so much more sound processing capabilities for voice modification, makes it real immersive for DND sessions, just can't drop it, even though there software solution and handling is a bit antiquated... Looking at my desk is a bit of a pain, seeing 4 audio devices sitting on top, but it is what it is...lol.
 
Last edited:

mvmiller12

[H]ard|Gawd
Joined
Aug 7, 2011
Messages
1,233
Also BSOD's EVERYTIME I would format and try to resinstall the drivers

Looking at my desk is a bit of a pain, seeing 4 audio devices sitting on top, but it is what it is...lol.

Man, I have a full receiver driving my Dolby Digital 5.1 setup (powered from main PC by an Auzentech Home Theatre HD X-Fi card) and a Roland MT-32 and a Roland SoundCanvas SC-55MkII and a mixing board to connect all of that (in addition to the SoundBlaster AWE64 Gold and GUS from the 486 and it's 17" CRT that are ALSO) sitting on my desk. I feel you on this.
 
  • Like
Reactions: Ikasu
like this

harmattan

Supreme [H]ardness
Joined
Feb 11, 2008
Messages
5,015
Wish this has come up a few weeks ago before I got my Asus Xonar DB.
 
Top