ASRock UEFI RAID Setup - No Driver Mapping / Detected?


Mar 10, 2000
RAID setup instructions I've been following: Pro3+/English.pdf

Hoping someone can point me in the right direction as I feel like I've tried every combination of settings I can think of in the UEFI control panel and I'm still at a loss.

Brand new FM2A88M Pro3+ ITX motherboard. I have 2 hard drives installed (plugged into SATA_1 and SATA_2). Detected by the UEFI control panel interface as normal, but when I follow the directive to change the RAID mode to UEFI and load up the EFI Shell, a message shows nothing is mapped and when I execute the 'drvcfg' command, I get a blank result.

My goal is to set up these 2 identical hard drives in RAID 1 configuration for subsequent installation of the linux OS (Amahi). From there I want to add 2 more (much larger) drives as auxiliary storage drives also in RAID 1.

To be clear, the current hard drives are in known good condition (previously used in another setup) and if I test out the Legacy ROM (MBR) setup, everything looks to work just fine which leads me to conclude I'm just not setting something up correctly.

Not sure what to do at this point. Any ideas of how to diagnose this problem??

(SIDE NOTE: Can't believe it's been more than 10 years since my last post. Yikes.)
Update: It helps if I read the WHOLE document. Especially the part where it says "for A88X chipsets." ;)

I had a few oddball hiccups where rebooting with the flash drive installed caused it to "forget" the UEFI "version" of the flash drive. When the UEFI version did show up in the boot menu (from a cold boot), I was able to successfully load the EFI shell and initialize the discs using the rcadm command as described.

At least I think I was successful. The command to create a RAID 1 array from the 2 initialized disks was followed by a "created successfully" response.

The next hurdle is trying to install Fedora 23 Server without crashing, but to at least find out if I got the drives set up correctly I tested out running a Windows 10 installation process up to choosing the OS location. That worked after loading the RAID drivers via USB so I have to assume that my problem now lies in getting Linux to play nicely. Not sure if I need to custom load "AMD RAID drivers" prior to running the installation process (I'm new to Linux).